phpMyAdmin正确的安装配置参数详解

时间:2019-05-11 09:46来源:计算机教程
$cfg['Servers'][$i]['controluser'] = ''; //控制用户用户名 $cfg['Servers'][$i]['controlpass'] = ''; //控制用户密码   之前只用phpmyadmin登录本地的mysql,管理另一个远程数据库的时候发现,单纯用命令行处

$cfg['Servers'][$i]['controluser'] = ''; //控制用户用户名
$cfg['Servers'][$i]['controlpass'] = ''; //控制用户密码

 

之前只用phpmyadmin登录本地的mysql,管理另一个远程数据库的时候发现,单纯用命令行处理字符串、换行符实在是不好使,所以配置了远程登录mysql,很简单的问题结果没有搜到合适的方法,所以记录下我的配置方式。

F.设置默认语言与编码
查找 $cfg['DefaultLang'] = 'zh'; (这里是选择语言,zh代表简体中文的意思) 还有 $cfg['DefaultCharset'] = 'gb2312';(修改默认编码为国标)

$cfg['Servers'][$i]['host'] = 'localhost'; //localhost改为目标地址

D.认证方法
$cfg['Servers'][$i]['auth_type'] = 'cookie';
在此有四种模式可供选择,cookie,http,HTTP,config
   config方式即输入phpmyadmin的访问网址即可直接进入,无需输入用户名和密码,是不安全的,不推荐使用。
   当该项设置为cookie,http或HTTP时,登录phpmyadmin需要数据用户名和密码进行验证,,具体如下:
   PHP安装模式为Apache,可以使用http和cookie;
   PHP安装模式为CGI,可以使用cookie
   我个人建议:无论是本地还是网络上,都建议设置成cookie,安全第一。

phpmyadmin/config.inc.php

2.配置config文件
  打开libraries下的config.default.php文件,依次找到下面各项,按照说明配置即可:

只修改该文件并不能达到目的,网上某教程只修改了这个文件。从另一个地方找的资料,还需要修改以下:

 

对了,phpmyadmin的默认路径在htdocs下边。

解决方法如下:

$cfg['Servers'][$i]['host'] = 'localhost'; //localhost改为目标ip地址;

phpmyadmin PHP 5.3 is required问题解决办法]

phpmyadmin/libraries/config.default.php

这种情况其实是站长们下载的phpmyadmin软件版本太新,最低要php5.3.x以上的版本才(www.111cn.net)能支持,否则低于该版本不会运行,而提示这个错误,解决的办法是下载一个低版本的即可,如php4.0

搞定!

1.先到网上下载phpmyadmin,再解压到可以访问的web目录下(如果是虚拟空间,可以解压后通过ftp等上传到web目录下),当然您可以修改解压后该文件的名称。

改完这一步可以登录访问,但每次提示都会提示“使用配置文件中定义的控制用户连接失败”,还需要修改以下:

 

  好了,到此为止,您已经成功安装了phpmyadmin,简单吧 ,赶快登录体验下吧

编辑:计算机教程 本文来源:phpMyAdmin正确的安装配置参数详解

关键词: